wfyj.net
当前位置:首页 >> struts1和struts2jAr >>

struts1和struts2jAr

是struts1 struts1和struts2是完全不同的两种框架,标签不一样action写法啥的都不一样 建议多学习struts2吧

看你要什么需求了,最基本的5个包不能少,分别是commons-logging-api-1.1.jar,freemarker-2.3.16.jar,ognl-3.0.jar,struts2-core-2.2.1.1.jar,xwork-core-2.2.1.1.jar 如果需要上传文件就需要commons-fileupload-1.2.1.jar,若要用到json则...

struts2.1.8所必须的jar包如下: commons-fileupload-2.1.8.jar; commons-io-1.3.2.jar; freemarker-2.3.16.jar; javassist-3.7.ga.jar; ognl-3.0.jar; struts2-core-2.1.8.1.jar; xwork-core-2.1.8.1.jar Struts 2是Struts的下一代产品,...

http://struts.apache.org/download.cgi 官网提供最新的2.5.2 页面中点击: struts-2.5.2-lib.zip (19MB) [PGP] [MD5] 下载解压后 找找有你想要的jar maven 中最低版本也就是2.1.8 org.apache.struts struts2-json-plugin 2.1.8

首先,struts2进行权限验证是用拦截器做的 一个简单的登录拦截器示例如下: package com.zdf.interceptor; import com.opensymphony.xwork2.Action; import com.opensymphony.xwork2.ActionInvocation; import com.opensymphony.xwork2.intercep...

1、看看是不是struts的架包冲突了。 2、看看stuts.xml里面的package有没有继承struts-default

只需要保留这个struts2-spring-plugin.jar:http://mvnrepository.com/artifact/org.apache.struts/struts2-spring-plugin/2.3.16.3

struts2-json-plugin-2.1.8.1.jar 这个是跟struts配套使用的 jsonplugin-0.34.jar 这个是单独使用的 如果要跟struts整合必须用第一个,如果单纯用json的话,两个应该都差不多,但最好用第二个

是不是jar包冲突了 我帮你百度了下 我看的文章他是spring的jar冲突(spring.jar --- spring-core.jar) 应该差不多 我还没有干着行只是学完了,错了别介意

这是2.21的初始包,跟2.1差不多的 commons-fileupload-1.2.1.jar commons-io-1.3.2.jar freemarker-2.3.16.jar javassist-3.7.ga.jar ognl-3.0.jar struts2-core-2.2.1.jar xwork-core-2.2.1.jar

网站首页 | 网站地图
All rights reserved Powered by www.wfyj.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com